UAlinux y Mint Maya: Distribución conflictiva

El otro día añadí el repositorio de ualinux para descargar algún juego para pasar el rato, y curiosamente recibí el siguiente mensaje de error de apt(el cual no me había encontrado nunca):

W: Distribución conflictiva: http://archive.ualinux.com maya Release (se esperaba maya, pero se obtuvo precise)

Efectivamente, yo había indicado en mi sources.list como distribución maya(que es la ultima versión de Linux Mint, y la que entendí que era la más similar a mi LMDE.

En un principio pensé que se trataba de algún error de mi sistema, pero revisé y estaba todo correcto.

¿De donde viene el error entonces? De la configuración del repositorio. Si revisamos el archivo http://archive.ualinux.com/ubuntu/dists/maya/Release , podemos comprobar en su cabecera el siguiente contenido:

Archive: precise
Version: 12.04
Components: main
Origin: Ubuntu (UALinux)
Label: Ubuntu (UALinux)
Architectures: i386 amd64
Suite: precise
Codename: precise
Description: Ubuntu (UALinux) precise 12.04
Date: Fri, 08 Jun 2012 07:06:01 UTC

Todo parece indicar que al realizar la configuración de las diferentes ramas del repositorio usaron el archivo de precise (de Ubuntu) como base y se han olvidado de cambiarlo.

Asimismo, el archivo http://archive.ualinux.com/ubuntu/dists/maya/main/binary-i386/Packages tiene en las rutas de todos los archivos un prefijo ../ftp/ que hará que devuelva un bonito 404 al intentar actualizar

Evidentemente, ya les he avisado, por lo que supongo que no tardarán demasiado en solventarlo 🙂

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.